Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2026 - 07:30 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 30, 2026 - 14:03 CEST
Scheduled
During this window, GoTallo may be temporarily unavailable while maintenance is carried out. The window has been scheduled early in the morning to minimize disruption. This page will be updated once maintenance is complete.
Posted Jun 30, 2026 - 13:57 CEST
This scheduled maintenance affected: API, Salesforce Sync, Inbound Messages, and Outbound Messages.